
WinEdit Help Index
The Index lists Help topics available for WinEdit. Use the scroll bar to see entries not currently visible in 
the Help window.
To learn how to use Help, press F1 or choose Using Help from the Help menu.
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WinEdit Keys
Use the following keys in WinEdit:

Moving the Insertion Point
Key(s)                                             Function  
Up Arrow Moves up one line.
Down Arrow Moves down one line.
Right Arrow Moves right one character.
Left Arrow Moves left one character.
Ctrl+Right Arrow Moves right one word.
Ctrl+Left Arrow Moves left one word.
Home Moves to the beginning of the line.
End Moves to the end of the line.
PgUp Moves up one window.
PgDn Moves down one window.
Ctrl+Home Moves to the beginning of the document.
Ctrl+End Moves to the end of the document.

Selecting Text
Key(s)                                             Function  
Shift+Left or Right Arrow Selects text one character at a time to the left or right. Or, if the character

is already selected, cancels the selection.
Shift+Down or Up Selects one line of text up or down. Or, if the line is already selected, 

cancels the selection.
Shift+Home Selects text to the beginning of the line.
Shift+End Selects text to the end of the line.
Ctrl+Shift+Left Arrow Selects the previous word.
Ctrl+Shift+Right Arrow Selects the next word.
Ctrl+Shift+PgUp Selects the previous screenful.
Ctrl+Shift+PgDn Selects the next screenful.
Ctrl+Shift+Home Selects to the beginning of the document.
Ctrl+Shift+End Selects to the end of the document.

Help Keys
Key(s)                                             Function  
F1 WinEdit Help Index
Shift+F1 Extended Help



WinEdit Commands
To get help with a command, choose the appropriate menu:

File Menu Commands
Edit Menu Commands
Search Menu Commands
Compile Menu Commands
Window Menu Commands



WinEdit Procedures
To get help with a procedure, choose the appropriate topic:

Changing Printers and Printer Options
Compiling (Running other programs)
Control Bar
Copying, Cutting, and Pasting Text
Creating New Documents
Deleting Text
Extended Help
Finding Text
Printing Documents
Printing Headers and Footers
Saving Documents
Setting Preferences
Setting Margins
Undo and Redo
Using Regular Expressions



File Menu Commands
New
Opens a new window with a new, untitled document
Open
Opens a new window with a new, existing document.    WinEdit can read an ASCII text file as large as 
available Windows memory.
Save
Saves the current document.    The window remains open.
If the document is UNTITLED, WinEdit prompts you for a document name.
Save As
Saves a document after prompting you for a new name.
Print
Prints the current document using the print settings entered in the Page Setup dialog box.
Page Setup
Allows you to set the margins, headers, footers, printer font, and page layout.
Printer Setup
Sets printer options for WinEdit before printing.
Preferences
Allows you to choose the screen font WinEdit uses, the tab size, whether the ControlBar is shown, and 
startup file options.
Exit
Closes all open windows and exits WinEdit.    If there are any unsaved files, WinEdit prompts you before 
exiting.



Edit Menu Commands
Undo
Allows you to "undo" previous editing actions.    WinEdit can undo the following:

Inserting a character.
Deleting a character.
Cutting a selection.
Pasting a selection.

WinEdit can undo the last 2000 editing actions.
Redo
Allows you to reverse any Undo commands.      After "redoing" edits, the Undo position is reset with the 
next editing action.
Cut
Removes the current selection from the document and places it on the clipboard.
Copy
Places a copy of the current selection on the clipboard without removing it from the document.
Paste
Pastes the text in the clipboard into the document at the insertion point.
Delete
Removes the current selection from the document without changing the contents of the clipboard.    If 
there is no selection, removes the character to the right of the insertion point.
Insert Mode
Toggles WinEdit between Insert mode and Overtype mode.
Select All
Selects all the text in the document.



Search Menu Commands
Find
Searches for text in a document.
You can specify these options:
* Find Type the text you want to find.
* Match case Select this box to match the upper and lower case exactly.
* Next Search forward starting at the insertion point.
* Previous Search backward starting at the insertion point.

Repeat Last Find
Repeats the last search using the same options, without opening the Find dialog box.

Change
Searches for text in a document and replaces the found text with text you specify.
You can specify these options:
* Find Type the text you want to find.
* Replace with Type the text you want to insert in place of the found text.
* Match case Select this box to match the upper and lower case exactly.
* Search backwards Search backward starting at the insertion point.
* Confirm before changing When text is found, you will be prompted before the change takes place.
* Change All Start at the current position, and search the entire document.    You will 

be prompted before each change takes place if the Confirm before 
changing box is selected.

Next Error
Prev Error
If any warning or error messages have been captured from the output of one of the Compile 
Menu items, these menu choices allow you to review the messages and the corresponding 
source code.

View Compiler Output
If any of the Compile menu commands captured output, this command will open a new 
document window and load the captured output file.

Related Topic:
Using Regular Expressions



Compile Menu Commands
The commands on this menu allow you to run other programs from within WinEdit.    Use the Configure... 
command to enter the necessary command to run the program.
Select the Capture Output box and WinEdit will run the program you configure and save its output.    
When the program finishes, WinEdit will ask if you wish to review any warning or error messages, along 
with the corresponding source code.
WinEdit constructs a batch file to execute from DOS when you choose to capture output.    For this 
reason, when running a Windows application from the Run menu, do not choose to capture the output.

Related Topic:
WinEdit Project Files



Window Menu Commands
Tile
Arranges all open document windows side by side so that all windows are visible.
Cascade
Arranges all open document windows in an overlapping pattern so that the title bar of each window is 
visible.
Arrange Icons
Arranges all document icons into rows.
Close All
Closes all open document windows.    If a document has changes that need saving, you will be prompted 
to save the document before closing.
Document Name
Each open window is listed on the menu by name.    Choose the name and that window will become the 
active document window.



Changing Printers and Printer Options
Select Printer Setup from the File menu to change printer settings.

Select Page Setup from the File menu to change the printer settings for margins, header, footer, printer 
font, and page layout.    WinEdit will remember these settings from session to session.

Related Topic:
Printing Documents
Printing Headers and Footers
Setting Margins



Compiling (Running other programs)
The first five commands on the Compile menu are user-configurable commands to execute another 
program.    You may configure these commands to execute any .EXE    or .BAT program by typing the 
command text in the appropriate Configure... edit box..
If the program supports DOS redirection (as most compilers and linkers do) you can select the Capture 
Output box to have WinEdit capture the program's output in a file.    When the program has executed, 
WinEdit will allow you to review any messages generated, along with the corresponding source code.
WinEdit constructs a batch file to execute from DOS when you choose to capture output.    For this 
reason, when running a Windows application from the Run menu, do not choose to capture the output.

Related Topic:
WinEdit Project Files



Control Bar
The Control Bar allows you to access some frequently used commands by clicking an icon for the 
command.    The Control Bar also has a drop-down list of the most recently opened files.    You can turn 
the Control Bar on or off from the File Preferences menu.

File List
Select a file name from the list by pressing and holding the left mouse button on the down arrow.    Move 
the mouse to highlight a file name, and release the mouse button.

To return without opening a new file, move the highlight up until the current file name is highlighted (it's 
always the first name in the list).

Icons

Open File.

Save File.

Print File.

Edit Cut.

Edit Copy

Edit Paste

Find Text.

Change Text.

Compile.

Make.

Rebuild.

Debug.

Execute (Go).

The next three icons are only visible on SuperVGA and above resolution monitors:

Previous Error.

Next Error.

Key word Help (Extended Help).



Copying, Cutting, and Pasting Text
To copy and paste, or cut and paste text:
1. Select the text.
2. Choose Copy from the Edit menu to copy the selected text to the clipboard.    Or choose Cut from
the Edit menu to cut the text to the clipboard.
3. Move the insertion point where you want the text to appear.    Or select text you want the pasted 
text to replace.
4. Choose Paste from the Edit menu.

Shortcut methods:    
Keypad + copies the current line to the clipboard if nothing is selected.    If there is a selection, Keypad+ 
is the same as Edit Copy.
Keypad - cuts the current line to the clipboard if nothing is selected.    If there is a seleciton, Keypad - is 
the same as Edit Cut.

Related Topic:
Deleting Text



Creating New Documents
Choose New from the File menu to open a new, untitled document window.



Deleting Text
To delete text without sending it to the clipboard:
1. Select the text.
2. Choose Delete from the Edit menu or press the Delete key.
If there is no selection, Delete deletes the character to the right of the insertion point.

Related Topic:
Copying, Cutting, and Pasting Text



Extended Help
Press Shift+F1 or click the Right Mouse Button on any Windows SDK function, message, or data 
structure name and WinEdit will access the SDKWIN.HLP topic for that item.

If the word is not a valid Windows SDK topic, WinEdit will pass the word to QH.EXE (Microsoft's 
QuickHelp program, supplied with most Microsoft language products).    This will allow you online access 
to any language or library keyword covered in the QuickHelp database.

For SDK Help, the WinHelp file SDKWIN.HLP must be in either the current directory, the Windows 
directory, or a directory listed in your PATH statement.

For QuickHelp, QH.EXE must be in either the current directory, the Windows directory, or a directory listed
in your PATH statement.    In addition, you must have an environment variable "HELPFILES=" defined 
which tells QH.EXE where to look to find the appropriate QuickHelp database files.



Finding Text
Choose Find from the Search menu to search for text in a document.
You can specify these options:
* Find Type the text you want to find.
* Match case Select this box to match the upper and lower case exactly.
* Next Search forward starting at the insertion point.
* Previous Search backward starting at the insertion point.

Choose Repeat Last Find to repeat the last search using the same options, without opening the Find 
dialog box.

Choose Change to search for text in a document and replace the found text with text you specify.
You can specify these options:
* Find Type the text you want to find.
* Replace with Type the text you want to insert in place of the found text.
* Match case Select this box to match the upper and lower case exactly.
* Search backwards Search backward starting at the insertion point.
* Confirm before changing When text is found, you will be prompted before the change takes place.
* Change All Start at the current position, and search the entire document.    You will 

be prompted before each change takes place if the Confirm before 
changing box is selected.

Related Topic:
Using Regular Expressions



Using Regular Expressions
A regular expression is a search or replace string that uses special characters to match text patterns.    
WinEdit supports UNIX style regular expressions.

When WinEdit conducts a search using regular expressions, it must check character by character in your 
text.    For this reason, searches using regular expressions are slower than regular searches.

The following table describes the regular expression characters recognized by WinEdit.

Expression Description
          \ Escape. WinEdit will ignore any special meaning of the character that 

follows the Escape expression.    Use the Escape if you need to search 
for a literal character that matches a regular expression character.

          . Wild Card. Matches any character.    For example, the expression 'X.X' 
will match 'XaX', 'XbX, and 'XcX', but not 'XaaX'.

          ^ Beginning Of Line. The expression matches only if it occurs at the 
beginning of a line.    For example, '^for' matches the text 'for' only when it
occurs at the beginning of a line.

          $ End Of Line. The expression matches only if it occurs at the end of a line.
For example, '(void)$' matches the text '(void)' only when it occurs at the 
end of a line.

          [ ] Character Class. The expression matches any character in the class 
specified within the brackets.    Use a dash (-) to specify a range of 
character values. For example, '[a-zA-Z0-9]' matches any letter or 
number, and '[xyz]' matches 'x', 'y', or 'z'.

          [ ^ ] Inverse Class. The expression matches any character not specified in 
the class.    For example, '[^a-zA-Z]' matches any character that is not a 
letter.

          * Repeat Operator. Matches zero or more occurences of the character that
precedes the '*'.    For example, 'XY*X' matches 'XX', 'XYX', and 'XYYX.

          + Repeat Operator. Matches one or more occurences of the character that 
precedes the '+'.    For example, 'XY+X' matches 'XYX' and 'XYYX, but 
not 'XX'.

Related Topic:
Finding Text



Printing Documents
Choose Print from the File menu to send the current document to the printer.

Related Topic:
Changing Printers and Printer Options
Printing Headers and Footers
Setting Margins



Printing Headers and Footers
Choose Page Setup from the File menu to configure header and footer text.    Type the text you wish to 
appear at the top and bottom of each page.

You can use the following special characters in headers and footers:
* %f The document name will appear.
* %d The date and time of the printout will appear.
* %p The page number will appear.

Related Topic:
Changing Printers and Printer Options
Printing Documents
Setting Margins



Saving Documents
Choose Save from the File menu to save a document.    Choose Save As to save the document with a 
new name, or to save an untitled document.



Setting Preferences
Choose Preferences from the File menu to choose a screen font and default tab size.    You can also 
choose whether or not to show the Control Bar, and startup file loading options.



Setting Margins
Choose Page Setup from the File menu to change the margins used for printouts.    You can enter the 
measurements for top, bottom, left, and right margins.
The margin settings are in inches or centimeters, corresponding to the English or Metric Measurement 
setting in Control Panel.

Related Topic:
Changing Printers and Printer Options
Printing Documents
Printing Headers and Footers



Undo and Redo
Undo
Allows you to "undo" previous editing actions.    WinEdit can undo the following:

Inserting a character.
Deleting a character.
Cutting a selection.
Pasting a selection.

WinEdit can undo the last 2000 editing actions.
Redo
Allows you to reverse any Undo commands.      After "redoing" edits, the Undo position is reset with the 
next editing action.



WinEdit Project Files
WinEdit saves the information from the Configure... dialog box in a private INI file with an extension of
.WPJ (WinEdit Project File).    Choose the Save... pushbutton to save the contents of the dialog box in 
a .WPJ file.    Choose the Open... pushbutton to load an existing .WPJ file.


